Sorry, you need to enable JavaScript to visit this website.

Accelerating openCV with zynq on Zedboard (Xilinx appnote 1167)

Unsolved
8 posts / 0 new
Umair.razzaq's picture
Umair.razzaq
Junior(0)
Accelerating openCV with zynq on Zedboard (Xilinx appnote 1167)

Hi,
I am trying to run newly realeased xapp1167(http://www.xilinx.com/support/documentation/application_notes/xapp1167.pdf) for accelerating openCV with zynq on Zedboard. That app is originally for zc702 board. At first I tried to run this application as it is explained but did not work on Zedboard (expected).

In order to run this on zed board, I created a new boot.bin file (by make boot as in app note) using the FSBL and U-Boot binary for Zedboard from xilinx wiki release (http://www.wiki.xilinx.com/Zynq+14.5+-+2013.1+Release). Also replaced the devicetree.dtb file in the sd_image with the one for ZedBoard from above release. Now I am able to boot the processors. but when i try to run the application i get following error
zynq> ./run.sh
Error : cann't open framebuffer device /dev/fb0

The application needs to interact with hdmi port but I suspect it is somehow not detected. Can anyone suggest me what needs to be done in order to get the hdmi port working or simply get rid of this error.

thanks
umair

AlbertaBeef's picture
AlbertaBeef
Moderator(5)
ZedBoard port of XAPP1167

Umair,

The XAPP1167 application note is built on top of the XAPP890 reference design.

This reference design has been ported to ZedBoard, and will soon be posted on ZedBoard.org ...

Please wait for this version and start from there ...

Regards,

Mario.

Umair.razzaq's picture
Umair.razzaq
Junior(0)
any update

Hi,
Are there any updates regarding this app note for zedboard.

umair

AlbertaBeef's picture
AlbertaBeef
Moderator(5)
XAPP890 Base TRD ZedBoard Port

Umair,

The ZedBoard port of XAPP890 is now available.

http://www.zedboard.org/projects
XAPP890 Base TRD ZedBoard Port

Regards,

Mario.

kychen's picture
kychen
Junior(0)
xapp1167 Base TRD ZedBoard Port

Hi,

I have tried to run the XAPP1167 on Zedboard for weeks, but it still didn't work. Is there any updates for this TRD to run on the Zedboard? Or where can I find related setting options information?

xchen10's picture
xchen10
Junior(0)
I have the same problem with

I have the same problem with you,have you solved it yet?
Please give me some suggestions,Thank you!

thchiou's picture
thchiou
Junior(3)
Start from XAPP890

We had a lot issues setting up and run XAPP1167 as well. However, we did get it working by exporting the Vivado HLS code as a ISE compatible IP, than start from XAPP890 and replace the Sobel filter IP with Fast IP (all connection stays the same). Right now we can run the design and see boxes being drawn around each feature points. You can give that a try.

-Kevin

saf176's picture
saf176
Junior(0)
Hi,

Hi,

Did you start from the XAPP890 original or from the one already for ZedBoard?
Now i'm trying to use the XAPP890 for ZedBoard, but one core is blocked and need a special license that i cannot buy. Can you help me, please?

Thank you!