Sorry, you need to enable JavaScript to visit this website.

Accessing PicoZed 7030 eMMC in u-boot

Solved
4 posts / 0 new
nitsch
Junior(0)
Accessing PicoZed 7030 eMMC in u-boot

We are using PicoZed 7030 on a FMCv2 carrier board. Running a custom Linux from SD card, we can access both the SD card as well as the on-board eMMC (after explicitly enabling sdhci1 in the device tree). In u-boot, however, the only available mmc device is the SD card. What is necessary to also access eMMC in u-boot?

zedhed
Moderator(28)
RE: Accessing PicoZed 7030 eMMC in u-boot

Hi nitsch,

I have only had experience accessing one or the other (SD card or eMMC) from U-boot since usually having both are not needed in an end application though potentially useful during development.

You may need to dig into the U-Boot source to find out an answer to your question but I have seen this recently come across where it appears that updates from the SD card to eMMC contents are possible once you declare the second SDHCI controller in platform-top.h header:

https://github.com/Avnet/petalinux/blob/master/configs/u-boot/platform-t...

Perhaps something similar would work for your application?

Best Regards,

-Kevin

nitsch
Junior(0)
We tried enabling only one of

We tried enabling only one of the MMC devices, but the SD card is the only one that works in u-boot. The one for the eMMC is never listed. So it currently is either SD card or nothing.

Thanks for the link. We are not using Petalinux but we will have a look at what they might be doing differently from a vanilla Xilinx u-boot.

nitsch
Junior(0)
We fixed it. It was an

We fixed it. It was an oversight on our part. Sorry for the noise.

When building the u-boot, make sure to use the picozed defconfig, not the zed defconfig. Duh.

The u-boot uses its own set of device tree files, apparently built into the u-boot image. Sources for these files are found in arch/arm/dts/. The one for zed only enables sdhci0 (the SD card) but not sdhci1 (the eMMC). This explains the behaviour we were observing. The dts for picozed only enables the latter by Default, which makes the eMMC work. Editing the dts to enable sdhci0 and sdhci1 makes it possible to access both SD card and eMMC in u-boot.