Sorry, you need to enable JavaScript to visit this website.

AXI DMA test errors on Petalinux

Unsolved
10 posts / 0 new
jarios86's picture
jarios86
Junior(0)
AXI DMA test errors on Petalinux

Hi everyone,
I'm trying to use the axi_dma xilinx driver in order to make transfer between PS and PL in both way. I posted this issue on the xilinx forum but I didn't get any response.
This is the link: https://forums.xilinx.com/t5/Embedded-Development-Tools/AXI-DMA-test-err...
Any idea?? I have looked for across the web but I cannot be able to manage the axidma engine.
Thanks in advance
Best,

JFoster's picture
JFoster
Moderator(48)
Hi Jarios86,

Hi Jarios86,

For educational support I am going to ask that you ask this question over at the Digilent Forum. 

https://forum.digilentinc.com/

Also one thing I noticed is you were using Vivado 2016.3 and Petalinux 2016.4. It is always suggest to use matching versions when possible. For instance Vivado 2016.4 and Petalinux 2016.4.

Thanks,

Josh

jarios86's picture
jarios86
Junior(0)
Hi @JFoster,

Hi @JFoster,
Now I'm using the same version (2016.3) for both software, Vivado and Petalinux. But the problem persists.
How can I follow the message in the forum (https://forum.digilentinc.com/) that you posted it. I cannot find the post.
Best,
Antonio

JFoster's picture
JFoster
Moderator(48)
Hi Antonio,

Hi Antonio,

Switching to both using 2016.3 is a good start! I am going to ask that you now repost your question over to Digilent as they are the main point of contact for educational support with the Zedboard.Once you do make your post, if you could please provide a link back to us so we can follow along that would be greatly appreciated.

Thank you,

Josh

jarios86's picture
jarios86
Junior(0)
Hi @JFoster

Hi @JFoster
Sorry, but I'm not using the Zedboard, I'm using the Zynq7100 MMP (Mini Module Plus) board from Avnet.
Best,
Antonio

jarios86's picture
jarios86
Junior(0)
Sorry, you mean Zedboard as

Sorry, you mean Zedboard as company or as board?

jarios86's picture
jarios86
Junior(0)
Hi @JFoster

Hi @JFoster
I have just posted on digilent forum my question.
This is the link: https://forum.digilentinc.com/topic/3695-axi-dma-test-errors-on-petalinux/
Best,
Antonio

JFoster's picture
JFoster
Moderator(48)
Hi Antonia,

Hi Antonia,

My apologies, for some reason I thought you were using a Zedboard FPGA. I'll take another look at your error.

--Josh

JFoster's picture
JFoster
Moderator(48)
Hi Antonio,
jarios86's picture
jarios86
Junior(0)
Hi Josh,

Hi Josh,
I have already seen this links many times. The two first links are for a non linux implementation, they are for standalone, but this is no my case.
The last one is related for how implement your own driver using the xilinx_dma driver. I checked it few months ago, but I would like tto test first the axi_dma_test in order to ensure that the configuration is fine. But the problem is that I cannot run the axi_dma_test, so I suspect that there is probably something wrong on my configuration, but I don't know what.
Best,
Antonio