Sorry, you need to enable JavaScript to visit this website.

Bare Metal AMP Apllication use IRQ on both Cores

Unsolved
6 posts / 0 new
jhoormann's picture
jhoormann
Junior(0)
Bare Metal AMP Apllication use IRQ on both Cores

I tried to write an Application, uses IRQs from the PL on Core0 and Use USB0IRQ on Core1. I start the Application seperatly and it works fine. I use the -DUSE_AMP=1 flag in BSP for Core1 and the USBIRQ is comming very slow, so that WIndows shows an Unknown USB Device. The IRQ was Mapped to Core1 with the  XScuGic_InterruptMaptoCpu(&InterruptController, CPU_1, XPAR_PS7_USB_0_INTR); function, in IRQ init on CPU0. SDK Version is 2016.4. Can anyone help me.
Thanks a lot.

JFoster's picture
JFoster
Moderator(48)
Hello Jhoormann,

Hello Jhoormann,

Which one of our development boards are you using?

--Josh

jhoormann's picture
jhoormann
Junior(0)
Hi Josh,

Hi Josh,
thanks for fast Reply, i have the Microzed 7010 on Avnet Microzedboard and no additional Devboard, instead of that a own board, which has same DAC, ADC, EEPROM via SPI, programmed via PL spi, for each device one spi. I will have a look to the shop and say you, which board it is

jhoormann's picture
jhoormann
Junior(0)
AES-Z7MB-7Z010-SOM-G

I have take a look at the shop, and the board at the desscription below is it...

AES-Z7MB-7Z010-SOM-G

JFoster's picture
JFoster
Moderator(48)
Hi,

Hi,

Try taking a look at lab9 of the Developing Zynq Software Speedway

http://zedboard.org/course/developing-zynq%C2%AE-7000-all-programmable-s...

In lab 9 we demonstrate a baremetal amp application similar to what you are trying to do.

--Josh

jhoormann's picture
jhoormann
Junior(0)
Lab number 9 from Speedway do

Lab number 9 from Speedway do, it worked, in my application are also working the 2 cores, but the irq on core1, i have routet came, but with much delay....