Sorry, you need to enable JavaScript to visit this website.

Cannot connect 2014.4 SDK to zedboard on linux

Unsolved
2 posts / 0 new
winksaville's picture
winksaville
Junior(0)
Cannot connect 2014.4 SDK to zedboard on linux

I'm trying to follow the tutorial:

http://zedboard.org/course/developing-zynq%C2%AE-7000-all-programmable-s...

And all is well until lab 5 and I can't connect to
the zedboard. I'm using 2014.4 SDK on Ubuntu 14.04.
For good or bad I've installed the drivers from

/opt/Xilinx/SDK/2014.4/data/xicom/cable_drivers/lin64/install_script/install_drivers/install_drivers

Below is the output from dmesg and we see ttyACM0 and ttyUSB0 setup:

[ 46.165247] usb 3-3: new high-speed USB device number 2 using xhci_hcd
[ 46.186229] usb 3-3: New USB device found, idVendor=0403, idProduct=6014
[ 46.186234] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 46.186236] usb 3-3: Product: Digilent USB Device
[ 46.186239] usb 3-3: Manufacturer: Digilent
[ 46.186241] usb 3-3: SerialNumber: 210248570449
[ 46.425146] usb 3-4: new full-speed USB device number 3 using xhci_hcd
[ 46.445927] usb 3-4: New USB device found, idVendor=04b4, idProduct=0008
[ 46.445932] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=4
[ 46.445935] usb 3-4: Product: Cypress-USB2UART-Ver1.0G
[ 46.445937] usb 3-4: Manufacturer: 2012 Cypress Semiconductor
[ 46.445939] usb 3-4: SerialNumber: 03680155280E
[ 46.453987] usbcore: registered new interface driver usbserial
[ 46.453999] usbcore: registered new interface driver usbserial_generic
[ 46.454008] usbserial: USB Serial support registered for generic
[ 46.457113] cdc_acm 3-4:1.0: This device cannot do calls on its own. It is not a modem.
[ 46.457135] cdc_acm 3-4:1.0: ttyACM0: USB ACM device
[ 46.457402] usbcore: registered new interface driver ftdi_sio
[ 46.457415] usbserial: USB Serial support registered for FTDI USB Serial Device
[ 46.457500] ftdi_sio 3-3:1.0: FTDI USB Serial Device converter detected
[ 46.457538] usb 3-3: Detected FT232H
[ 46.457540] usb 3-3: Number of endpoints 2
[ 46.457541] usb 3-3: Endpoint 1 MaxPacketSize 512
[ 46.457543] usb 3-3: Endpoint 2 MaxPacketSize 512
[ 46.457545] usb 3-3: Setting MaxPacketSize 512
[ 46.457646] usb 3-3: FTDI USB Serial Device converter now attached to ttyUSB0
[ 46.459150] usbcore: registered new interface driver cdc_acm
[ 46.459152] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

But for the life of me I can't figure out how to connect the SDK to
these devices. Any help appreciated!!

-- Wink

winksaville's picture
winksaville
Junior(0)
Connected

I followed the instructions of Sven Andersen’s blog Zynq design from scratch. Part 13
(http://svenand.blogdrive.com/archive/172.html#.VHe8Verd-90).
and installed the Adept 2 runtime and utilities
(http://www.digilentinc.com/Products/Detail.cfm?NavPath=2,66,828&Prod=ADEPT2).
I grabbed the “linux tar” files to my home Downloads diretory and untar’d them
(tar -xvf xx) and as Sven advised I installed them as suggested by the install script
to their default locations. I didn’t install plugin for ISE which I don’t have and
is now deprecated. Also I didn’t install the 52-digilent-usb.rules
to /etc/udev/rules.d as it was already there, probably from the sdk or vivado install.

I then ran udevadm to reinit and tried the “djtgcfg enum”:

wink@ssi-primary:~/Downloads$ djtgcfg enum
Found 1 device(s)

Device: Zed
Product Name: Digilent Zed
User Name: Zed
Serial Number: 210248570449

But the “djtgcfg init -d Zed” didn’t work:

wink@ssi-primary:~/Downloads$ djtgcfg init -d Zed
ERROR: unable to init JTAG, err code=3 << Something like this

So I rebooted and guess what it worked!!

wink@ssi-primary:~/Downloads$ djtgcfg init -d Zed
Initializing scan chain...
Found Device ID: 23727093
Found Device ID: 4ba00477

Found 2 device(s):
Device 0: ARM_DAP
Device 1: XC7Z020

I was then able to complete step 7 of experiment 1 "Program the FPGA", of lab 5, Yea!

Next was experiment 2 where we run the Hello_Zynq app. Here 14.4 is different from the
vivado 13.3 and rather than an “Initialization” tab there is a “Target Setup” tab which
was already populated with ps7_init.tcl, so I skipped step 3. And then step 4 didn’t
work because the options for the STDIO configuration only had /dev/ttyS0 or JTAG and
I needed /dev/ttyACM0.

So I fired up minicom and saw the Hello World output, finally.

$ sudo minicom -D /dev/ttyACM0 -b 115200 -8 -o