Sorry, you need to enable JavaScript to visit this website.

Help me ~! I can't use usb otg in zedboard.

Unsolved
3 posts / 0 new
ywkim's picture
ywkim
Junior(0)
Help me ~! I can't use usb otg in zedboard.

hi everyone~!
i use 
Petalinux 2013.10 + vivado 2013.4 + analogdevices-kernel + zedboard
so i  get a result HDMI Display. it is work very well. 
but, i can't use usb-otg port. 
I implemented it by referring to the following site.
https://2015_fall_nctu_esd.hackpad.com/ep/pad/static/2ApxmX0YBiH
One of the above site contents is different.
git checkout 2014_R1.
and i check all of it and devicetree(system.dts) following site.  
http://www.wiki.xilinx.com/Zynq+Linux+USB+Device+Driver
i can not fine follworing message in petalinux booting (dmesg).
 
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
 
and when i connect mouse to usb-otg, the mouse is not work(no power). 
but if i use other kernel, the mouse is work very well.  
why this happen... ? i don't know. 
please let me know~!!
 
Thank. 
Best regards. 
 
note: 
i found one thing.

The analog device kernel does not have a "driver / usb / otg" folder. Is it related to this?
 
 
 
 
 

narrucmot's picture
narrucmot
Moderator(1)
You mention you are using

You mention you are using PetaLinux 2013.10 and Vivado 2013.4?  To validate the USB OTG is working I would duggest downloading and installing the PetaLinux 2013.10 ZedBoard BSP from the Xilinx archive:

(https://www.xilinx.com/support/download/index.html/content/xilinx/en/dow...

Once the BSP is installed you can examine the devicetree and compare to your current settings.

 

ywkim's picture
ywkim
Junior(0)
oh~ Thank you so much~!!

oh~ Thank you so much~!!
i will try to do so...!!