Sorry, you need to enable JavaScript to visit this website.

How can I build Matrix Multiply Project for MiniZed

Unsolved
3 posts / 0 new
crossofheat
Junior(0)
How can I build Matrix Multiply Project for MiniZed

Hello
I tried to setup MiniZed Platform on SDx 2017.4 according to Avnet MiniZed SDSoC Platform Install instructions.
 
But, I faced problem in "Experiment 3".
SDx failed to building Matrix Multiply Project with the following error messages.
 
What's a cause of this build error?
Does anyone help me?
 

Create board support package library

Link application ELF file

C:/Xilinx/SDx/2017.4/target/aarch32-none/lib\libsds_lib.a(xlnk-core-dma-standalone.o): In function `xlnkSetUpRing.constprop.2':

xlnk-core-dma-standalone.c:(.text+0x28): undefined reference to `XAxiDma_BdRingSetCoalesce'

xlnk-core-dma-standalone.c:(.text+0x60): undefined reference to `XAxiDma_BdRingCreate'

xlnk-core-dma-standalone.c:(.text+0x80): undefined reference to `XAxiDma_BdRingClone'

xlnk-core-dma-standalone.c:(.text+0x90): undefined reference to `XAxiDma_BdRingStart'

C:/Xilinx/SDx/2017.4/target/aarch32-none/lib\libsds_lib.a(xlnk-core-dma-standalone.o): In function `xlnkDMASubmit':

xlnk-core-dma-standalone.c:(.text+0x3d0): undefined reference to `XAxiDma_BdRingAlloc'

xlnk-core-dma-standalone.c:(.text+0x44c): undefined reference to `XAxiDma_BdSetBufAddr'

xlnk-core-dma-standalone.c:(.text+0x464): undefined reference to `XAxiDma_BdSetLength'

xlnk-core-dma-standalone.c:(.text+0x48c): undefined reference to `XAxiDma_BdSetAppWord'

xlnk-core-dma-standalone.c:(.text+0x4b8): undefined reference to `XAxiDma_BdSetAppWord'

xlnk-core-dma-standalone.c:(.text+0x4d8): undefined reference to `XAxiDma_BdSetCtrl'

xlnk-core-dma-standalone.c:(.text+0x53c): undefined reference to `XAxiDma_BdRingToHw'

C:/Xilinx/SDx/2017.4/target/aarch32-none/lib\libsds_lib.a(xlnk-core-dma-standalone.o): In function `xlnkDMAWait':

xlnk-core-dma-standalone.c:(.text+0x8d8): undefined reference to `XAxiDma_BdRingFromHw'

xlnk-core-dma-standalone.c:(.text+0x8fc): undefined reference to `XAxiDma_BdRingFree'

xlnk-core-dma-standalone.c:(.text+0x944): undefined reference to `XAxiDma_BdRingFromHw'

C:/Xilinx/SDx/2017.4/target/aarch32-none/lib\libsds_lib.a(xlnk-core-dma-standalone.o): In function `xlnkDmaRegister':

xlnk-core-dma-standalone.c:(.text+0xb14): undefined reference to `XAxiDma_CfgInitialize'

collect2.exe: error: ld returned 1 exit status

ERROR: [SdsCompiler 83-5019] Exiting sds++ : Error when calling 'arm-none-eabi-g++ -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -Wl,--build-id=none -specs=C:/Xilinx/SDx/2017.4/data/toolchain/aarch32-none.spec -Wl,-T -Wl,C:/Avnet/platforms/mz_avnet/sw/config0/lscript.ld  C:/Avnet/SDx_workspace/MiniZedMM/Debug/_sds/swstubs/mmult.o C:/Avnet/SDx_workspace/MiniZedMM/Debug/_sds/swstubs/main.o   -L C:/Avnet/SDx_workspace/MiniZedMM/Debug/_sds/swstubs/standalone_bsp/ps7_cortexa9_0/lib  -L C:/Xilinx/SDx/2017.4/target/aarch32-none/lib -LC:/Avnet/SDx_workspace/MiniZedMM/Debug/_sds/swstubs -Wl,--start-group -lxilffs -lgcc -lc -lstdc++ -Wl,--end-group -Wl,--start-group   -lxilffs -lxil -lgcc -lc  -lsds_lib -lxlnk_stub -lgcc -lc -Wl,--end-group -o C:/Avnet/SDx_workspace/MiniZedMM/Debug/_sds/swstubs/MiniZedMM.elf'

sds++ log file saved as C:/Avnet/SDx_workspace/MiniZedMM/Debug/_sds/reports/sds.log

ERROR: [SdsCompiler 83-5004] Build failed
 
Thank you.   

crossofheat
Junior(0)
Downgrade the SDx

-----------------Progress report---------------
I  downgraded SDx to 2017.1.
Then, project building was success.
 
However I had next trouble.
When I tried to flash BOOT.BIN, it failed with following messages.
I  used Command Line Tool 2017.4.
So, Should i downgrade it such as SDx too? 
---------------------------------------------------------------------------------------------------------------

xsct% exec program_flash -f boot.bin -fsbl MiniZedMM.elf -flash_type qspi_single

 

 

****** Xilinx Program Flash

****** Program Flash v2017.4 (64-bit)

  **** SW Build 2086221 on Fri Dec 15 20:55:39 MST 2017

    ** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

 

Connecting to hw_server @ TCP:localhost:3121

 

WARNING: Failed to connect to hw_server at TCP:localhost:3121

Attempting to launch hw_server at TCP:localhost:3121

 

Connected to hw_server @ TCP:localhost:3121

Available targets and devices:

Target 0 : jsn-MiniZed V1-1234-oj1A

        Device 0: jsn-MiniZed V1-1234-oj1A-4ba00477-0

 

Retrieving Flash info...

 

Initialization done, programming the memory

BOOT_MODE REG = 0x00000001

WARNING: [Xicom 50-100] The current boot mode is QSPI.

If flash programming fails, configure device for JTAG boot mode and try again.

Problem in Initializing Hardware

Flash programming initialization failed.

 

ERROR: Flash Operation Failed

zedman2000
Moderator(3)
Hi there,

Hi there,

Yes, you will need to use version 2017.1 for everything.
There are some pretty big changes coming in the 2017.4 versions of everything and we are still working on documenting the changes for this. Until then, if you wish to use the 2017.1 version of the MiniZed Platform, you will need to use THAT version of the tools as platforms are tool version specific.

--Dan