Sorry, you need to enable JavaScript to visit this website.

Internal PL LED Access

Solved
9 posts / 0 new
Walden95's picture
Walden95
Junior(0)
Internal PL LED Access

I have a Microzed XC7010 board and am trying to access an available onboard LED for debug information for the PL side of the board.
From the schematics, it seems that the only appropriate LED is the Blue LED on the DONE_0 port of Bank 0. However, I'm not finding it easily accessible to the PL without having to go outside the board. How can I connect to this or any other LED to the PL?
Thanks!

JFoster's picture
JFoster
Moderator(48)
Hello Walden,

Hello Walden,

The Blue Done Led is not a user axxessible led. That Led is enumerated when the bitstream was sucessfully loaded into the pfga. The only user LED is a PS led (D3). Take a look at the hardware user guide section 2.6.2

http://zedboard.org/support/documentation/1519

--Josh

Walden95's picture
Walden95
Junior(0)
Is there a way to connect

Is there a way to connect that pin to something the PL can use?
For the Blue LED, I would need a GND pin and the FPGA_DONE pin connected externally.
For that Red LED, I would need a way to send a signal between the PS and PL since the PL does not have acess to Bank 501. Is there a block for this similar to creating a clock for the PL?

JFoster's picture
JFoster
Moderator(48)
Hello Walden,

Hello Walden,

That blue led is not accessible to you. If you wish to create a clock in the PL, you can enable a PL clock by double clicking on your Zynq Processor then going to the Clock configuration settings. When in the clock configuration settings you can enable/define the frequency of up to 4 PL clocks.

--Josh

Walden95's picture
Walden95
Junior(0)
Thanks JFoster,

Thanks JFoster,
I'm moving onto something else at the moment, but I just want to make sure that we are on the same page regarding that Blue LED if I so choose to come back to it, or for anyone else curious. I've included the images that I was looking at in the schematic that made me think it was accessible.
 

 
I understand now that I can't access Bank 0 from the PL.
However, I do not understand why it is not possible to control the Blue LED via the first microheader (JX1), even if that means I need to hook a wire or two (Probably GND through a tri-state-buffer) externally to the board. Is there some state whilst the board is on and programmed that pulls FPGA_DONE to GND (Turning off the Blue LED) that makes it unsuitable for use?
Thanks for your responses.

Walden95's picture
Walden95
Junior(0)
Because the images didn't

Because the images didn't show, and I can't edit the post...
Image 1
Image 2
Image 3
 

JFoster's picture
JFoster
Moderator(48)
Hello Walden,

Hello Walden,

The blue Led is an indicator that shows when the FPGA has been properly loaded with a Hardware Bitstream. In no case (Unless you made physical modifications) can you program the bitstream correctly and have the blue LED indicator off.

My suggestion would be for you to use one of the Carrier Cards if you wish to access a LED via the PL.

--Josh

NoellEagan's picture
NoellEagan
Junior(0)
Hi...i am a new user here. As

Hi...i am a new user here. As per my knowledge the Blue Done Led is not a user axxessible led. That Led is enumerated when the bitstream was sucessfully loaded into the pfga. The only user LED is a PS led (D3).

JFoster's picture
JFoster
Moderator(48)
Hello Noel,

Hello Noel,

That is correct.

Thanks,

Josh