Sorry, you need to enable JavaScript to visit this website.

PetaLinux BSP for UltraZed-EG Starter Kit

Unsolved
13 posts / 0 new
mark.suska
Junior(1)
PetaLinux BSP for UltraZed-EG Starter Kit

Where can I download the PetaLinux BSP for the UltraZed-EG Starter Kit?

mark.suska
Junior(1)
What is the  ZED BSP found on

What is the  ZED BSP found on Xilinx site? Is this what I need for to reproduce the Out-Of-Box (OOB) for the UltraZed-EG Starter Kit?
https://www.xilinx.com/support/download/index.html/content/xilinx/en/dow...

mark.suska
Junior(1)
PetaLinux BSP for UltraZed-EG Starter Kit

What is the ZED BSP found on Xilinx site? Is this what I need for to reproduce the Out-Of-Box (OOB) for the UltraZed-EG Starter Kit?
https://www.xilinx.com/support/download/index.html/content/xilinx/en/dow...

JFoster
Moderator(67)
Hello mark,

Hello mark,

You can find the UltraZed SOM+IO Carrier Card BSP located here http://zedboard.org/support/design/17596/131

Currently we only have the 2016.2 version available, we are in the process of updating it.

The ZED BSP you found is the Petalinux BSP that targets the ZedBoard hardware.

--Josh

mark.suska
Junior(1)
software versions

Thanks Josh.
Do all the software versions have to be the same? i.e.:

  • Vivado SDK 2016.2
  • UltraZed Board Definition files 2016.2
  • PetaLinux 2016.2
  • UltraZed SOM+IO Carrier Card BSP 2016.2

Or, can I use the latest version of Vivado SDK with the latest UltraZed Board Definition files (which seem to be 2016.4) and will it work with older PetaLinux? i.e.:

  • Vivado SDK 2017.1
  • UltraZed Board Definition files 2016.4
  • PetaLinux 2016.2
  • UltraZed SOM+IO Carrier Card BSP 2016.2

 

xsteve
Junior(0)
Any news on the BSP update

Any news on the BSP update process?
I have to use 2017.1 for my project.
I am able to build the Linux Image fro 2016.2. But it fails when I try to use the 2017.1 SDK together with the 2016.2 BSP
Can you give a hint when the 2017.1 BSP will be available?
 
Thanks,
  Stefan.

I'm waiting for 2017.1 BSP

I'm waiting for 2017.1 BSP also as 2016.2 BSP didn't work with 2017.1 SDK and Petalinux.
Can it be available soon?
Thanks,
Iris

JFoster
Moderator(67)
Hello Iris,

Hello Iris,

We are still working on the BSPs, sorry about the delay.

--Josh

JFoster
Moderator(67)
Hello Mark,

Hello Mark,

I would always suggest for you to have the same software versions. In some cases mismatching various software versions has caused some issues.

--Josh

JFoster
Moderator(67)
Hello,

Hello,

The 2017.2 BSP has been posted for both UltraZed IO Carrier Card and PCIE Carrier Card.

--Josh

kapi
Junior(0)
2018 BSP

Hello, are there any plans for 2018.2 BSP upgrade?

zesmu
Junior(0)
Any idea at least, when the

Any idea at least, when the 2018.2 update/upgrade could show up?
And an update of the board_files, which work on 2018.2?
Thanks ...

JFoster
Moderator(67)
Hello Zesmu,

Hello Zesmu,

We are still working on the 2018.2 BSP release. As far as the board definition files, we are not planning on updating these. The previous versions will still work for 2018.2.

You can find the most up to date BDFs and current petalinux BSP work located here

https://github.com/Avnet

--Josh