Sorry, you need to enable JavaScript to visit this website.

ping to picoZed doesn't work

Unsolved
2 posts / 0 new
jesortsan's picture
jesortsan
Junior(0)
ping to picoZed doesn't work

Hi, I have a picoZed board with a Zynq 7020 plugged into a FMC Carrier Rev C.
I've followed the steps detailed in "http://architechboards-picozed.readthedocs.io/en/latest/quick.html#", even running my Ubuntu host machine on Oracle VM VirtualBox, but I got stuck at "2.6 Debug" paragraph.
I've configured eth0 properly on picoZed (I've checked it by ifconfig).
I guess I've also configured eth0 properly on Ubuntu VM.
But when I'm doing ping to the board, I get "http://architechboards-picozed.readthedocs.io/en/latest/quick.html#" message. Ping from board to Ubuntu VM doesn't work either.
Netmasks are correct on both interfaces (255.255.255.0), so I guess I'm missing something because this is nor working.
I've also tried to do ping from an Ubuntu and from a Windows machines (configuring eth0 properly), in order to avoid using the VM (just in case that was the problem), but I have the same error messages in both cases.
I've also tried the same procedure booting with the kernel located in Flash memory (instead of the one in SD Card compiled with bitbake), but results are the same.
Any idea? This is my second attempt (several months after the first time) to start developing with picoZed board and I'm a bit discouraged.
Best regards
Jesus
BTW: I'm using a crossover Ethernet cable and link LED is ON on both sides.

JFoster's picture
JFoster
Moderator(55)
Hello Jesortsan,

Hello Jesortsan,

Have you tried to ping your PicoZed using the baremetal Lwip application? I have actually documented this basic design. You can find it here http://picozed.org/support/design/13076/106 under Tutorial 05. Please try this, it will help determine if your hardware or Network is at fault.

--Josh