Sorry, you need to enable JavaScript to visit this website.

Problem Booting from SD Card

Unsolved
7 posts / 0 new
sixperf's picture
sixperf
Junior(0)
Problem Booting from SD Card

I am running ISE 14.4. I have created a couple of simple projects that I can run successfully from SDK on the ZED board. One of the projects, for example, is from Xilinx application note UG873(v14.4) - Concepts, Tools, and Techniques. This project is the "Embedded System Design Using PS and PL" in chapter 3. The design uses AXI GPIO and AXI Timer with interrupt.

I am now trying to run the project from the SD card. I built the first stage boot loader and the boot image for the SD card successfully. I copied the boot image, BOOT.BIN, to the SD card so that BOOT.BIN is the only file on the SD card, reconfigured the ZED jumpers for SD booting, and attempted to boot from the SD card. But nothing happens. I don't see the blue LED light when the FPGA is programmed successfully. I know the SD card works because I can reinstall the original boot files for Linux and boot successfully.

I also tried booting the other project that I created, from the SD card, but get the same result.

fletch's picture
fletch
Moderator(15)
Did you include the bitstream

Did you include the bitstream when you created boot.bin? What order did you put the FSBL, .bit, and your application?
Bryan
 

sixperf's picture
sixperf
Junior(0)
Hello Bryan,

Hello Bryan,

When I created the boot image, the "Create Zynq Boot Image" window showed the fsbl file first, the bit file next, and the application elf file as last.

Bob

fletch's picture
fletch
Moderator(15)
Is your application targeted

Is your application targeted to run from DDR or OCM? I have seen an application in the past that worked fine when running from OCM, but when combined with FSBL, the combination exceeded the OCM.
Just to confirm, are you able to manually configure the bitstream and run the application from SDK?
Everything else that you are doing sounds correct. I searched the Xilinx Answers Database for issues with 14.4 bootgen, but I don't see any.
Bryan

sixperf's picture
sixperf
Junior(0)
targeting application for DDR or OCM?

Hello Bryan,
I am not sure how to target my application to run on DDR or OCM. I created my first project by following the example in application note UG873 chapter 3 as I described earlier. I am able to run the application successfully from SDK. The bitstream created successfully. I then created the fsbl and the boot image and programmed the SD card. I followed the procedure given for this in the Zynq introductory Avnet/Speedway seminar book, lab 8 which I attended.

If there was a choice to choose DDR or OCM to run the application, I don't remember it. Is this referenced in one of the app notes?

Thanks,

Bob

mikelsoto's picture
mikelsoto
Junior(0)
Problem Booting from SD Card

Hi Bob, the same happens to me. With the bitstream of my design the flash is not programmed and therefore the BOOT.BIN doen't work, and with other designs it works. However, programing the fpga with the SDK my bitstream works properly.

Have you find the solution to your problem?

L30nardoSV's picture
L30nardoSV
Junior(0)
Problem Booting from SD Card

Hello, I have exactly the same problem.
Did you find the way to solve this?
BTW, I am using the Zedboard REv.D ...
Many thanks in advance.