Sorry, you need to enable JavaScript to visit this website.

Problems on zvik_camera_linux_app of "xapp 794"

Unsolved
6 posts / 0 new
louislxw's picture
louislxw
Junior(0)
Problems on zvik_camera_linux_app of "xapp 794"

Hi,

I am working on the Xillinx Design "xapp 794" and have problems as follows.

With the reference of xapp 794, I knew that the video from the camera can be processed by the defined console command. However, when I used the command of "record" to save one bmp image into SD card, the picture will not have the effect (like auto white balance, enhance and so on) which can be seen from the display. Is there anyone can help me? Thank you!

TroutChaser's picture
TroutChaser
Moderator(18)
First you will need to

First you will need to provide a little more information:
Are you trying to implement this on the ZC702 evaluation board as is done in XAPP794 or a ZedBoard?  
Are you using the same Vivado version (2013.2) the xapp does or are you using another version of the Xilinx tools?
What is your host operating system?
 
Also, please do not post your question on multiple forums. I will delete the duplicate post under the Software Application Forum.
 
-Gary

louislxw's picture
louislxw
Junior(0)
Dear Gary,

Dear Gary,

Thanks for your reply.

Yes, I am trying to implement this design (XAPP794) on the ZC702 evaluation board, and I also use the same Vivado version (2013.2). My host operation system is Windows 7.

Could you offer me some assistance?

Thank you!
Louis

TroutChaser's picture
TroutChaser
Moderator(18)
Xilinx issue

Hello Louis,
 
As you are trying to implement a Xilinx xapp on a Xilinx evaluation board you will probably receive a better response on the Xilinx community forums: http://forums.xilinx.com/t5/Zynq-All-Programmable-SoC/bd-p/zaps
 
We are focused on the Avnet supplied and supported Zynq boards like the ZedBoard, MicroZed, Zynq MMP, and Zynq Mini-ITX on this forum and do not have a lot of experience with the Xilinx boards.
 
-Gary

louislxw's picture
louislxw
Junior(0)
avnet design

Dear Gary,

I have noticed that the design "zvik_camera_linux_app" is the property of Avnet, and I send an e-mail to technical.support@avnet.com at first. However, there is an automatic reply said that,

If you have a question about an Avnet Zynq development board, please use the ZED Forums at http://www.zedboard.org/forums/zed-english-forum

I have also post a topic with my problem in Xilinx User Community Forum, but with no reply. So I wonder whether you could offer me some assistance?

Regards,
Louis

avnet505's picture
avnet505
Junior(0)
XAPP794 on Zedboard

Hi,

I'm trying to implement the 1080p60 Camera Image Processing
Reference Design on a Zedboard.
May I know what are the changes required? Any good source that I can refer to?

Regards,
Thing