Sorry, you need to enable JavaScript to visit this website.

SD card content invisible

Zedboard forums is currently read-only while it under goes maintenance.

Unsolved
2 posts / 0 new
fd9750
Junior(0)
SD card content invisible

Hi,

I have a microzed board that works really well. The SDK is installed on my laptop, it boots nicely from the QSPI flash and subsequently from the SD card, ending up with a Linux version 3.8.0 kernel + a functional shell. Downloading and executing applications works equally fine.

The only odd thing is that when I insert the micro SD card in the SD card adapter and put that into my PC I do not see a single file on the SD card, no boot image: just nothing at all.
Stick the micro SD card back in the Microzed micro SD slot and run the board again, sure enough: everything is perfect again.

Reading a FAT32 formatted SD card should be no problem at all for a standard WIN7 PC or am I missing something ?

Any help/suggestion much appreciated.

fd9750
Junior(0)
Problem solved

Scratch transmission, I had a closer look at the documentation and the SD card being empty is standard.
I was confused because when the board boots with or without an SD card there is a slight difference. Without an SD card you get a few error messages that basically say: I tried to mount the SD card but I could not find it. With an SD card you get a few messages saying it was able to mount the SD card.

Once you know it is glaringly obvious.