Sorry, you need to enable JavaScript to visit this website.

UART drivers not working in Win10 Pro/Home 64bit

Solved
9 posts / 0 new
Rathseg
Junior(0)
UART drivers not working in Win10 Pro/Home 64bit

Hi,

 

   I just got a Zedboard and I am trying to get it up and running but I am getting stuck right at the very beginning with getting the UART connection to work.  I followed the included instructions with the board.  I got the Green Power light, blue done light, "digilent" image on the OLED, and a solid amber light on the UART LD11.  

 

I went to the next step that says you need to install the driver for the Cypress CY7C64225  USB-to-UART.  I found the the 1.3 install guide from here: http://zedboard.org/support/documentation/1521  I went to the Cypress site, got the CypressDriverInstaller_1 file and installed it.  It said it installed fine(* there are discrepancies with the install guide after install, which I will get to in a minute ).  The amber light turned off instead of blinking.  Tried reconnecting the Zedboard, turning on/off, restarting computer.  In all cases, the UART amber light is off and I cannot connect with a terminal program.

 

Compared with the install guide there are some things that are different in the device manager.  There is no device listed as "CypressUsbConsoleWindowsDriver" as Figure 4/Step 9 shows.  Under Ports ( COM and LPT ),  it is called USB Serial Port ( COM4 ), not "Cypress Serial".   USB Serial Port is the Zedboard as it only appears if I turn on the Zedboard.  Going into the properties for the USB Serial Port under Port Settings->Advanced as steps 10 and 11 indicate, there is no option for Enable Port Persist, but under "Com Port Number" dropdown box ( bottom of the picture step 11 ), there is an option for "enable RTS-DTR Flow Control" and "Other Serial Device Setup" with the option "Compatible I2C Slave Device Address (7 bit Even Address ) with 0x42 in the textbox.  USB to UART Adapter is under "Universal Serial Bus Controllers" but is not mentioned in the install guide.

 

I started checking the forums and found this post: http://zedboard.org/content/uart-driver-does-not-work-new-pc and tried ALL the suggestions there with no change.  That thread was pretty old so I thought I'd start a new one.  If I uninstall everything and turn on the zedboard I can get the solid amber light back.

 

I also tried hooking up the Zedboard to a laptop running Windows 10 Home 64-bit, with the exact same results.

 

OS: Windows 10 Pro 64 bit

USB Serial Port Version number after Cypress driver install: 3.13.0.59 dated 10/13/2105

USB to UART Adapter Version number after Cypress driver install 3.13.0.59 dated 10/13/2015

 

I'm pretty much out of ideas at this point and could use some more suggestions.  A few other details.

 

Thanks in advance.

 

Rathseg
Junior(0)
I solved this.  The

I solved this.  The instructions are incorrect in several ways.  The amber LED only blinks if there is active traffic going to the UART ( e.g. connected via TeraTerm and watching the LED as you send a command ).  So when step 6 of the "Getting Started Instructions" card included with the device the instructions says you should see the light flash as an indicator as to whether or not you need to install the drivers; it is wrong because the light will not flash at that point no matter what.
The USB to UART driver installation instructions are also out of date or incorrect.  I finally got drivers working by manually installing the Win 7 versions from the extracted driver install directory.  Even in those, there is no "CypressUsbConsoleWindowsDriver as Figure 4/Step 9 shows, nor is there a setting for "Enable Port Persist" in the USB Serial Port driver properties ( steps 10 and 11 ).  Apparently, you don't need either of these.
Lastly, and this may be my bad since it has been a long time since I have had to use a terminal emulator, but when you connect via TeraTerm, it will sit there with just a cursor block and nothing else, which gave me the impression that it was trying to connect and was hanging/failing.  You have to hit return/enter and then it will respond with a prompt that says "zynq>".  To be fair though, I did try connecting via Putty when I first started with the Win10 drivers and got a timeout message.  Maybe my Putty telnet settings were off and the Win10 drivers are actually fine, but I don't care enough to double check since I have it working now.
Hopefully this will save other people from wasting a bunch of time like I did.
 

Mparker
Junior(0)
UART don't fogret baud rate

Thanks for the info, I ran into the same quirks.
One more thing, one must still set up your terminal program to the correct baud rate, etc. or no response will happen even though you are typing on the terminal.
I was using Tera Term and Windows 10 talking to a ZedBoard.
Click Setup tab > then click Serial Port > then enter
Port:  < whatever COM port you are on >
Baud Rate: 115200
Data: 8 bit
Parity: none
Stop: 1 bit
Flow control: none

Rathseg
Junior(0)
I don't know why my

I don't know why my formatting got all messed up, but there is only an edit option for my OP. Sorry if it is hard to read the solution.

JSC4
Junior(0)
Instructions on making it work

Hello, I too have the same problem you had, in terms of trying to get the ZedBoard to work on windows 10. You mentioned you solved the problem "I finally got drivers working by manually installing the Win 7 versions from the extracted driver install directory".
How do I go about by manually installing the Win 7 versions. Is there a file I need to download, and if so is there a link?

Rathseg
Junior(0)
Drivers

I'm going off memory here, but once you have downloaded the driver executable and tried to install them once the individual files are extracted to a temp directory and you can get the files from there.  It should say where they extract to during the process.  By default it is either C:\ or in your user temp directory.
 
I did have to reformat my computer due to other reasons and when I reinstalled the drivers, I don't remember if I did the part where I used the Windows 7 driver manually, its been a while.  It may be that the really important things are to know are the other things I mentioned like what should appear in the Device Manager and how/when the light blinks are wrong in the instructions.
Hope that helps.

JFoster
Moderator(69)
Hello JSC4,

Hello JSC4,

Please refer to the "Cypress USB-to-UART Setup Guide" http://zedboard.org/support/documentation/1521

--Josh

mpiazza2017
Junior(1)
Abbreviated Getting Started (Windows 10)

Hi,
I'm a 3rd year CE student interested in learning about the ZedBoard (no FPGA courses currently offered at my university, so I am helping a professor develop labs). I wrote down the minimum steps that I used to get the ZedBoard to display the same as the original Getting Started Instructions and I would like to share them here for other beginners. Please let me know if you spot any errors, and thanks for the helpful posts so far!
 
Getting Started Instructions (Windows 10)

1. Connect 12V power to J20.

2. Connect J14 to PC via MicroUSB.

3. Insert SD Card into J12.

4. Turn SW8 ON (LD13 should illuminate).

5. Wait ~15 seconds (LD12 should illuminate, DISP1 should display default image).

6. Open Device Manager from Windows search bar and expand the Port list to confirm COM Port.

7. Install/run "Tera Term" (from https://osdn.net/projects/ttssh2/releases/).

  a. Choose Serial and select same COM Port from step 6. Click OK.

  b. Click: Setup > Serial port:

    I. Confirm Port

    II. Baud Rate: 115200

    III. Data: 8 bit, 

    IV. Parity: none, 

    V. Stop: 1 bit, 

    VI: Flow control: none. 

    VII: Click OK.

8. Turn SW8 OFF, then ON (in Tera Term: Linux image should boot with ZedBoard demo).

9. Type "poweroff" in Tera Term (prolongs OLED life; executed prior to turning ZedBoard OFF).

10. Turn SW8 OFF.
 
 

fletch
Moderator(18)
Thanks for sharing. Another

Thanks for sharing. Another helpful resource for brand new users is the Xilinx University Program. See the free materials here:

https://www.xilinx.com/support/university/students.html#workshops

 

Bryan