Sorry, you need to enable JavaScript to visit this website.

UltraZed-EG ethernet not working

Solved
3 posts / 0 new
a.ineo
Junior(0)
UltraZed-EG ethernet not working

Hello Everyone,
 
I having issue with the ethernet interface on my UltraZed-EG.
Ethernet interface is working great when i use "uz3eg_iocc_2017_2.bsp".
But, i'm trying to make it works on my PetaLinux 2017.2 image generated with my hdf file (Vivado 2017.2).
The system boot correctly but the ethernet interface is not detected.
I found the following error message:
dmesg | grep ethernet

[    2.768313] macb ff0e0000.ethernet eth0: Could not attach to PHY

I try to generate a new image using the official hdf (nested in "uz3eg_iocc_2017_2.bsp") but i have the same error.

 

 

 

Thank you,

 

rgb-sti
Junior(0)
Updated board level dt?

Hi,
If you have created a new PetaLinux project using your hdf, have you also updated the board level device tree customisation?
If not, you can copy this from your original bsp. It's the system-user.dtsi, probably located in project-spec/meta-user/recipes-bsp/device-tree/files. This has the eth3 bindings required.
You may also need the other bindings from here to get some of the other components working.
 

a.ineo
Junior(0)
Solved using this:https:/