Sorry, you need to enable JavaScript to visit this website.

XPS License

Unsolved
16 posts / 0 new
Chaosmaster's picture
Chaosmaster
Junior(0)
XPS License

Hello,

I downloaded and installed Xilinx ISE WebPACK 14.2 to get started with Zynq before buying the Zedboard.

Then I followed this guide: ZedBoard_CTT_v14.1_120808.pdf (http://www.xilinx.com/university/zynq/documentation/ZedBoard_CTT_v14.1_1...) until page 13 where I get informed that I don't have a license for the XPS feature.

Do I have to buy a license or am I doing something wrong?

Best regards
Mathias

Limba's picture
Limba
Junior(0)
Hi,

Hi,

In ISE WebPACK compare chart it's shows XPS (Xilinx Platfor Studio) is locked to 3 smallest Zync devices.

Verify selected device.

OT:
I will now start to DL ISE 14.2 WebPACK.

Chaosmaster's picture
Chaosmaster
Junior(0)
I changed the device to a

I changed the device to a smaller one, the issue is still there. Any other ideas?

jonesa's picture
jonesa
Junior(0)
I just ordered my board and

I just ordered my board and am trying to get a headstart on development... however I am getting this same error on a fresh 14.2 download and install with the webpack license. I have no other versions installed.

If I launch XPS directly and just ignore the error on startup, I can still do a few things, but other things produce errors.

However, if I follow the CTT and XPS is launched from PlanAhead, it produces a second error:
INTERNAL_ERROR:PersonalityModule:baspmspec.c:1751:1.79 - Could not load definition file <qvirtex6.acd>
And does nothing else...

Any ideas?

praphan's picture
praphan
Junior(0)
Hi,

Hi,

You may need XPS license, I have same problem but when I try the evaluate license this problem is solve.

zynqgeek's picture
zynqgeek
Junior(0)
I have written up a licensing

I have written up a licensing guide here:

http://zynqgeek.blogspot.com/2012/08/xilinx-tools-install-and-license-ho...

I hope it is some help to you, as when I followed it I did not see any issues with EPS/EDK/SDK/PlanAhead licensing.

jonesa's picture
jonesa
Junior(0)
Thanks for the link.

Thanks for the link. Unfortunately, that page describes exactly what I did to obtain and install my license.

Can you post a screen shot of what your license list looks like after you install your webpack license (sorted by Version Limit)?

I end up with 8 licensed features with a green "Version Limit": xps_tdp, V_WebPACK, PlanAhead, WebPACK, Web_Package, and XC7Z010/XC7Z020/XC7Z030. Everything else is red.

What is somewhat interesting is that there are a ton of features which show builtin license up to "Version Limit" 2012.07, many of which are XPS related, and 14.2 is supposed to be 2012.2... I wonder if something is weird with those builtin features.

josephsamson's picture
josephsamson
Junior(0)
XPS Errors Too

I just got my Zynq board and I have the same problem as the OP. I'm running XP on VMWare Fusion.
I've downloaded and run the GPIO demo from the Booting and Configuration Guide, so some things are working with this setup.

josephsamson's picture
josephsamson
Junior(0)
Started Over But Still No Luck

I uninstalled 14.2 and removed the webpack license file from .Xilinx. Then I downloaded 14.2 again and generated a new WebPack license. I still get an XPS licensing error at page 13 of the Concepts, Tools and Techniques reference.

Hansi's picture
Hansi
Junior(0)
Annoying but working

I'm using ISE 14.2 on Linux 64 bit and also get a license error every time I start XPS. After clicking OK (and closing the licensing setup window), XPS continues to start up and I didn't find any further problems. Its just annoying to click that away every time.

Bye
Hansi

fletch's picture
fletch
Moderator(15)
7010, 7020, and  7030 are

7010, 7020, and  7030 are supposed to have XPS/SDK support in WebPACK.  However, there were some known issues in 14.1 that may have carried over into 14.2  I suggest you look at this thread and the referenced Answer Record.
http://www.zedboard.org/content/ise-141-webpack-install-work-arounds
Bryan

jonesa's picture
jonesa
Junior(0)
fixed

With a little help from Xilinx, I was able to get 14.2 working for me. It turns out that 14.2 has some of the same issues as 14.1, and you need to install Logic Edition or higher to work around this issue. I still get a license error popup every time XPS opens, but PlanAhead is able to launch XPS now so I am able to use the tools at least... the popup is annoying, but it still seems to work.

http://www.xilinx.com/support/answers/47839.htm

WEBPACK LICENCE ERROR

Hi all there is an issue with the 14.2 tool. Please ignore the pop up where it says licence not valid. You may continue. FOR those who get " INTERNAL_ERROR:PersonalityModule:baspmspec.c:1751:1.79 - Could not load definition file <qvirtex6.acd> " error. Please INSTALL FULL VERSION of the tool and use webpack licence. It will work fine! Tried and tested!

ChuckM's picture
ChuckM
Junior(0)
Still have errors in 14.4

So I've been struggling with this, I have downloaded several variations, I still get

INTERNAL_ERROR:PersonalityModule:baspmspec.c:1751:1.79 - Could not load definition file <qvirtex6.acd>

XPS says : Release Version 14.4 (nt64)
Application Version: Build EDK_P.49d+0

It said 14.5 is available so I'm downloading that (I really wish it would patch rather than re-download the whole thing but whatever)

I'm working off the Intro Tutorial (which is kind of out of data since it says PlanAhead doesn't know about Zedboard (it does now) and that the "real" tool would be Vivado (but I didn't find a tutorial for Vivado yet.) Any other ideas, perhaps the name of the package I am SUPPOSED to download as it appears on the Xilinx Download page? I don't think they could have made it more confusing!

mikebcd's picture
mikebcd
Junior(0)
vivado Licencing and MicroZed

Excited to discover MicroZed and Zyncland, but getting annoyed with licencing issues.
I am experienced with using Webpack ISE, but are admittedly new to Vivado. Have used the licence manager, and got licences for XC72010 and the other smaller parts; these show green.
But when running Synthesis I get messages like INFO: [Common 17-78] Attempting to get a license: Internal_bitstream
WARNING: [Common 17-301] Failed to get a license: Internal_bitstream
But also I see the message which looks good:
INFO: [Common 17-347] Attempting to get a license for feature 'Synthesis' and/or device 'xc7z010'
INFO: [Common 17-349] Got license for feature 'Synthesis' and/or device 'xc7z010'
But then I see :
INFO: [Common 17-78] Attempting to get a license: Synthesis
WARNING: [Common 17-301] Failed to get a license: Synthesis
Now when I try to add logic to the design, it just gets stripped out , and this thing just doesn't work!
I notice that Xilinx are dropping Webcase support as well.
So can anyone enlighten me about this, or shall I stick with ISE , which I have used for years?
( However ISim complains it cant simulate a Zync : and wont even start!)
Looking forward to some help here! Mike

mikebcd's picture
mikebcd
Junior(0)
vidado and microzed take-2

Hi there, and another day of Productivity. Zero.
Thought I was onto something , as ZyncBLOG mentions installing SYSTEM edition, but the Avnet documentation states DESIGN edition.
So uninstalled, and reinstalled. NO NEED! it was OK.
Two clues : (1)The VHDL project has missing unisim V components in system.bd : surely Vivado should have created VHDL equivalents. DONT try and import the Verilog directory cos there is no way of deleteing it again!
(2) So tried to create a Verilog project, and it doesn't now show errors for the grounds, but it is still not right.
(3) the log mentions ' xilinx ip preload is disabled' , and I think it is stripping out the whole design because the Zync IP is missing.
Does that sound along the right lines?
Appreciate some help here Xilinx!