Sorry, you need to enable JavaScript to visit this website.

Zedboard AMP solution

Unsolved
4 posts / 0 new
sundarravikumar's picture
sundarravikumar
Junior(0)
Zedboard AMP solution

Hello all,

I am trying out the Pre-canned AMP solution ( baremetal + Linux) on my Zedboard and i am facing some issues in getting it to work.

Initially i used the zynq-beta tagged repository to build by uboot from source and i could not make it work.
After that i also tried the xilinx-v14.5 tagged repository as mentioned in the Read me for the design Tutorial but still i get the same error

The error is i am not able to mount my ramdisk. The kernel Log is as below

Booting Linux on physical CPU 0x0
Linux version 3.8.0-xilinx (rs71ein@einz1693) (gcc version 4.7.2 (GCC) ) #1 SMP PREEMPT Mon Aug 5 19:37:27 CEST 2013
CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=18c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: Xilinx Zynq Platform, model: ZedBoard
bootconsole [earlycon0] enabled
INITRD: 0x1f8ca000+0x0028ac63 is not a memory region - disabling initrd
cma: CMA: reserved 16 MiB at 16c00000
Memory policy: ECC disabled, Data cache writealloc
PERCPU: Embedded 7 pages/cpu @c08c1000 s7616 r8192 d12864 u32768
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 97536
Kernel command line: console=ttyPS0,115200 root=/dev/ram maxcpus=1 rw ip=110.0.0.5::110.0.0.1:255.255.255.0::eth0:dhcp earlyprintk
PID hash table entries: 2048 (order: 1, 8192 bytes)
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
__ex_table already sorted, skipping sort
Memory: 384MB = 384MB total
Memory: 367332k/367332k available, 25884k reserved, 0K highmem
Virtual kernel memory layout:
vector : 0xffff0000 - 0xffff1000 ( 4 kB)
fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
vmalloc : 0xd8800000 - 0xff000000 ( 616 MB)
lowmem : 0xc0000000 - 0xd8000000 ( 384 MB)
pkmap : 0xbfe00000 - 0xc0000000 ( 2 MB)
modules : 0xbf000000 - 0xbfe00000 ( 14 MB)
.text : 0xc0008000 - 0xc052a754 (5258 kB)
.init : 0xc052b000 - 0xc0554dc0 ( 168 kB)
.data : 0xc0556000 - 0xc058e9e8 ( 227 kB)
.bss : 0xc058e9e8 - 0xc05b8f98 ( 170 kB)
Preemptible hierarchical RCU implementation.
Dump stacks of tasks blocking RCU-preempt GP.
RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=2.
NR_IRQS:16 nr_irqs:16 16
xslcr mapped to d8802000
Zynq clock init
ps7-ttc #0 at d8804000, irq=43
sched_clock: 32 bits at 100 Hz, resolution 10000000ns, wraps every 4294967286ms
Console: colour dummy device 80x30
Calibrating delay loop... 1064.96 BogoMIPS (lpj=5324800)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
Setting up static identity map for 0x3b7910 - 0x3b7944
L310 cache controller enabled
l2x0: 8 ways, CACHE_ID 0x000000c0, AUX_CTRL 0x72360000, Cache size: 524288 B
Brought up 1 CPUs
SMP: Total of 1 processors activated (1064.96 BogoMIPS).
devtmpfs: initialized
NET: Registered protocol family 16
DMA: preallocated 256 KiB pool for atomic coherent allocations
xgpiops e000a000.ps7-gpio: gpio at 0xe000a000 mapped to 0xd880c000
hw-breakpoint: found 5 (+1 reserved) breakpoint and 1 watchpoint registers.
hw-breakpoint: maximum watchpoint size is 4 bytes.
bio: create slab <bio-0> at 0
vgaarb: loaded
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
pps_core: LinuxPPS API ver. 1 registered
pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
PTP clock support registered
Switching to clocksource xttcps_clocksource
NET: Registered protocol family 2
TCP established hash table entries: 4096 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
TCP: reno registered
UDP hash table entries: 256 (order: 1, 8192 bytes)
UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
NET: Registered protocol family 1
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
hw perfevents: enabled with ARMv7 Cortex-A9 PMU driver, 7 counters available
jffs2: version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
msgmni has been set to 749
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
dma-pl330 f8003000.ps7-dma: Loaded driver for PL330 DMAC-267056
dma-pl330 f8003000.ps7-dma: DBUFF-128x8bytes Num_Chans-8 Num_Peri-4 Num_Events-16
e00010console [ttyPS0] enabled, bootconsole disabled
console [ttyPS0] enabled, bootconsole disabled
xdevcfg f8007000.ps7-dev-cfg: ioremap f8007000 to d8862000 with size 1000
brd: module loaded
loop: module loaded
xspips e0006000.ps7-spi: master is unqueued, this is deprecated
xspips e0006000.ps7-spi: at 0xE0006000 mapped to 0xD8864000, irq=58
xspips e0007000.ps7-spi: master is unqueued, this is deprecated
xspips e0007000.ps7-spi: at 0xE0007000 mapped to 0xD8866000, irq=81
xqspips e000d000.ps7-qspi: master is unqueued, this is deprecated
m25p80 spi2.0: found s25fl256s1, expected n25q128
m25p80 spi2.0: fallback to 3-byte address mode
m25p80 spi2.0: maximum accessible size is 16MB
m25p80 spi2.0: s25fl256s1 (32768 Kbytes)
5 ofpart partitions found on MTD device spi2.0
Creating 5 MTD partitions on "spi2.0":
0x000000000000-0x000000100000 : "qspi-fsbl-uboot"
0x000000100000-0x000000600000 : "qspi-linux"
0x000000600000-0x000000620000 : "qspi-device-tree"
0x000000620000-0x000000c00000 : "qspi-rootfs"
0x000000c00000-0x000001000000 : "qspi-bitstream"
xqspips e000d000.ps7-qspi: at 0xE000D000 mapped to 0xD8868000, irq=51
e1000e: Intel(R) PRO/1000 Network Driver - 2.1.4-k
e1000e: Copyright(c) 1999 - 2012 Intel Corporation.
xemacps e000b000.ps7-ethernet: error in getting phy i/f
xemacps: probe of e000b000.ps7-ethernet failed with error -22
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci-pci: EHCI PCI platform driver
ULPI transceiver vendor/product ID 0x0451/0x1507
Found TI TUSB1210 ULPI transceiver.
ULPI integrity check: passed.
xusbps-ehci xusbps-ehci.0: Xilinx PS USB EHCI Host Controller
xusbps-ehci xusbps-ehci.0: new USB bus registered, assigned bus number 1
xusbps-ehci xusbps-ehci.0: irq 53, io mem 0x00000000
xusbps-ehci xusbps-ehci.0: USB 2.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
mousedev: PS/2 mouse device common for all mice
i2c /dev entries driver
xadcps f8007100.ps7-xadc: Failed to request memory region
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pltfm: SDHCI platform and OF driver helper
mmc0: SDHCI controller on e0100000.ps7-sdio [e0100000.ps7-sdio] using ADMA
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP: cubic registered
NET: Registered protocol family 17
VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4
Registering SWP/SWPB emulation handler
dmatest: Started 1 threads using dma0chan0
dmatest: Started 1 threads using dma0chan1
dmatest: Started 1 threads using dma0chan2
dmatest: Started 1 threads using dma0chan3
dmatest: Started 1 threads using dma0chan4
mmc0: new high speed SDHC card at address 0007
mmcblk0: mmc0:0007 SD04G 3.70 GiB
dmatest: Started 1 threads using dma0chan5
mmcblk0: p1
dmatest: Started 1 threads using dma0chan6
dmatest: Started 1 threads using dma0chan7
List of all partitions:
1f00 1024 mtdblock0 (driver?)
1f01 5120 mtdblock1 (driver?)
1f02 128 mtdblock2 (driver?)
1f03 6016 mtdblock3 (driver?)
1f04 4096 mtdblock4 (driver?)
b300 3887104 mmcblk0 driver: mmcblk
b301 3883008 mmcblk0p1 00000000-01
No filesystem could mount root, tried: ext3 ext2 ext4 vfat msdos
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

I think this statement in the log is the culprit

"INITRD: 0x1f8ca000+0x0028ac63 is not a memory region - disabling initrd"

I made all the necessary changes to the device tree to reserve memory for the Linux and the bare-metal application. I am quite sure that the issue is something to do with Uboot. Since when i run generate my BOOT.bin with the already generated file ( which comes with the design) It could boot in. Any help will be greatly appreciated.

Cheers,
Sun

zackshef's picture
zackshef
Junior(0)
v14.3build 2

I've read that v14.3build2 is still what you need to use. I did have some issues trying to use newer versions, but this one worked for me.

Linux:
https://github.com/Xilinx/linux-xlnx/archive/xilinx-14.3-build2.tar.gz

U-boot:
https://github.com/Xilinx/u-boot-xlnx/archive/xilinx-14.3-build2.tar.gz

sundarravikumar's picture
sundarravikumar
Junior(0)
There are some SD card issues

There are some SD card issues with the xilinx-14.3 build of uboot, it is also mentioned in the xilinx wiki under known issues, hence i had to use a later version of uboot. Though i was able to solve this problem. it was because my Ram disk was getting copied outside the SDRAM region which Linux could see.

jakubon2's picture
jakubon2
Junior(0)
Solution

Hi there,

in bootargs for devicetree, set console=ttyPS1 for ZedBoard!

Ondrej