Sorry, you need to enable JavaScript to visit this website.

ZedBoard Rev.C + AD-FMCMOTCON2-EBZ

Unsolved
4 posts / 0 new
mikro's picture
mikro
Junior(0)
ZedBoard Rev.C + AD-FMCMOTCON2-EBZ

Hello everyone,
since 2 months I am in the world of ZedBoard.
I always got problems when I wanted to download the bitstreams per USB-UART interface and run the external simulation from Matlab per TCP/IP interface.
I need to try several times until one successful bitstream download or one successful external mode simulation.
 
I firstly contacted with Mathworks for this reason and it turned out, my ZedBoard Rev.C has also some hardware issues with itself. After reading the ZedBoard errata Rev.C, I did a hardware fix on USB-UART interface, but there is another issue for "SD Card Clock Series Termination", a 40 Ohm to 60 Ohm resistor in series needed on SDIO clock pin. I do not think I can fix it by my side. So this issue of SDIO clock pin will not be fixed.
 
My quesition or consideration: by downloading the bitstreams and by running external simulation, the SD card will be written too. So could the SDIO clock issue be a big problem by ZedBoard Rev. C, that the reading or writting files from SD card sometimes corruptted.
 
By the way, I also used the board AD-FMCMOTCON2-EBZ board for motor control from analog devices. Except this connection issue on ZedBoard Rev.C, everything works well.
Could this issue be solved with ZedBoard Rev.D or later?
Windows 10 64bit is my operation system + Matlab R2017a + Vivado 2016.2

mbrown's picture
mbrown
Moderator(7)
Hello mikro,

Hello mikro,

 

As stated in the ZedBoard Rev C1 Errata:

 

 

Unless you're observing signal integrity problems resulting in corrpupt data, the only action is to design your board with the termination resistor.

Thanks,

/Matt

mikro's picture
mikro
Junior(0)
Hi Matt,

Hi Matt,
thanks for your reply. For my design with Zynq, I will put a termination resistor on SDClock. But for my ZedBoard, it seems not possible.
I am not sure, whether this causes the whole problem by me, but anyway, I decide to use another board or a new ZedBoard in Rev D.
I just want to know, whether I am the only one who encounters this issue °--° ~~~
Best regards,
Mikro

mikro's picture
mikro
Junior(0)
updated info

I just want to upload an updated info.
1, this issue above was only for the case, if I wanted to download the bitstream to Zedboard with USB-UART interface.
2, the drive for USB-UART, Cypress has been installed correctly and I also tried to re-install it, but it did not help.
3, so SD card read/writing should not be the cause.