Sorry, you need to enable JavaScript to visit this website.

ZedBoard Software Lab 7

Unsolved
2 posts / 0 new
jyouney's picture
jyouney
Junior(0)
ZedBoard Software Lab 7

I have completed software lab 7 for the Zedboard. When I run my boot image it seems to run fine except it hangs on the line that tests the Ethernet port in the Test_Peripherals application. After seeing this behavior I decided to run the Test_Peripherals application in a jtag debug mode similar to what was done in SW Lab05. Here when I run the application it steps all the way through the application and does not hang at the line that tests the Ethernet port "Running Interrupt Test for ps7_ethernet_0..." What would cause this problem.

fletch's picture
fletch
Moderator(15)
Which version of Vivado are

Which version of Vivado are you using?
Have you tried plugging in an Ethernet cable to the board and a router to see if that makes a difference?
 
Since the Test_Peripherals application is auto-generated by Vivado, it sounds like this is a Xilinx tools issue. Also interesting that it works in debug mode. Did you also post on the Xilinx forums? If you learn what the issue is, please report back.
 
Bryan