Sorry, you need to enable JavaScript to visit this website.

Boot runs only partial application

Unsolved
2 posts / 0 new
fadilluquman's picture
fadilluquman
Junior(0)
Boot runs only partial application

Hello,
I am a newbie to the Zedboard. I am following the SW & HW labs provided by Xilinx. The pre-defined templates like the HelloWorld, MemoryTests, PeripheralTests etc seem to work fine on the Debug Build Configuration. However, when I tried to change the build configuration to Release(Active) from Lab6 & Lab7, the board doesn't seem to execute the complete application. I tried running the MemoryTests & PeripheralTests from Lab6 booting from the QSPI single, after programming it. The applications gets stuck @ "Running Interrupt Test  for ps7_ethernet_0..." for peripheral tests and no messages are printed for memory_tests, probably stuck at the beginning itself.
 
 
Kindly provide some insights to the issue.
Software Used
Vivado Design Suite 2015.3
 
Hardware
Default Zynq hdf
 
 
 

JFoster's picture
JFoster
Moderator(48)
Hello Fadilluquman,

Hello Fadilluquman,

Are you refering to the hardware/software labs located at this location? http://zedboard.org/support/trainings-and-videos

If so which lab version did you download? As you can see we only offer tutorials that support Vivado 2013.3/2014.4.1/2015.2/2016.2.

On another note if you look at a the 2016.2 lab documents, you will notice that we skipped the changing the build configurations to release(Active). The reason we did this is due to the issue you are currently encountering. This issue is caused by a bug with the tools that should have been fixed in the Vivado 2016.3 release. However I have not confirmed that fix myself.

--Josh