Sorry, you need to enable JavaScript to visit this website.

Linux Application

Unsolved
7 posts / 0 new
xspyder's picture
xspyder
Junior(0)
Linux Application

I want to make an application that will run on the linux that came with the zedboard. Can I design it and compile it using the Xilinx SDK? Then copy the executable over to the linux? Or do I somehow have to get the compiler and arm toolchain on that linux somehow and compile it there? Thanks!

zedhed's picture
zedhed
Moderator(25)
RE: Linux Application

Hi xspyder,

If you are creating a C application, you certainly can use Xilinx SDK to create, edit, manage, and debug your application.

When creating a new Xilinx C Project in SDK, make sure that you set the Software Platform option to Linux. This will build your application using the arm-xilinx-linux-gnueabi- tools.

You can copy the executable over to Linux by copying to the SD card, FTP, SCP, or using the SDK Remote System Explorer (RSE).

Regards,

-Kevin

xspyder's picture
xspyder
Junior(0)
I am trying to get a simple

I am trying to get a simple Hello World app to run in linux. I was able to successfully compile the ELF file in the SDK and upload it to linux that came with the zedboard. It worked fine. I then tried the same thing with xillinux (Ubuntu 12 LTS) and the ELF won't execute. I get the following:

root@localhost:/apps# ./Test.elf

bash: ./Test.elf: No such file or directory

Here is what I get when I use the file command:

root@localhost:/apps# file Test.elf

Test.elf: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, not stripped

root@localhost:/apps# ldd Test.elf
not a dynamic executable

I also did chmod +x Test.elf and that did not work. Could it be the different kernels? Ubuntu is running 3.3 and that file looks to be built for 2.6.16.

Any ideas?

eli's picture
eli
Junior(1)
Why not compile it directly on Xillinux?

Hi,

I suggest compiling your application in Xillinux (using gcc). Odds are that it will work on any distribution running Linux.

If the executable happens to depend on a library that exists on Xillinux, but on the target distribution, you may use the "-static" flag to tell gcc to generate a self-contained executable. The executable will be bigger, but this is usually a small penalty when it's a single program compiled this way.

I've never tried to use Xilinx' SDK for this, but I take Kevin's word for that it's possible, of course.

erickrieg's picture
erickrieg
Junior(0)
elf file (built on a Win PC with SDK) to run on Zynq

I'm using a Windows 7 PC with SDK and I have built several elf files and I have multiple ways to install them in a directory on the Zynq.  I've tried a few hours, set the X flag etc, but I can't figure out how to get them to execute on the board.  The only discussions I can find give vague discussions how someone could write some app to then cause an elf file to be executed.   My Zynq board powers up in some version of Linux, but it is not Petalinux and does not seem to have a TCF host - so I can't seem to run it from a remote debugger either.  Please help me figure something out before I start to look like an idiot to the bean counters.

Zaglikosh's picture
Zaglikosh
Junior(0)
Did it work?

I am facing the same problems in xillinux distribution. How did you overcome this problem?

Thank you in advance

Nicholas

MaxPohl's picture
MaxPohl
Junior(0)
execute permission

Hi,

i get an error message: Permission denied.
I get manually the execute permission, is there a way to compile a application already with all needed permissions?